Информатика, вопрос задал semenromanov1290309 , 7 лет назад

Напишите легкую программу в python \
программу к одной задаче из перечисленных
1)Ввести с клавиатуры пароль (символьную строку). Если его длина меньше, чем 6 символов, вывести сообщение «Слишком короткий пароль!». Если пароль начинается с букв «qwerty» вывести сообщение «Ненадёжный пароль!». Если ошибок не было, вывести сообщение «ОК».
2)Ввести с клавиатуры имя файла. Если расширение имени файла – htm, html или php, выдать сообщение «Это веб-страница!», иначе выдать сообщение «Что-то другое.»
3)Напишите программу, которая получает номер месяца и выводит соответствующее ему время года или сообщение об ошибке
4)Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». Например, «21 год», «22 года», «25 лет».

Ответы на вопрос

Ответил budzsergiy777p0i27m
0

import datetime

def task_1():

   """1)Ввести с клавиатуры пароль (символьную строку).  

   Если его длина меньше, чем 6 символов, вывести сообщение

   «Слишком короткий пароль!».Если пароль начинается с букв «qwerty»

   вывести сообщение «Ненадёжный пароль!».  

   Если ошибок не было, вывести сообщение «ОК»."""

   def password(string):

       if len(string) >= 6:

           if string[0] in 'qwerty':

               print("Ненадёжный пароль!")

           else:

               print("OK")

       else:

           print("Слишком короткий пароль!")

   password('yqzudzas')

def task_2():

   """2)Ввести с клавиатуры имя файла.  

   Если расширение имени файла – htm, html или php,  

   выдать сообщение «Это веб-страница!», иначе  

   выдать сообщение «Что-то другое.»"""

   def name_file(name):

       a = name.split('.')[-1]

       if ('htm' or 'html' or 'php') in name.split('.')[-1]:

           print('Это веб-страница!')

       else:

           print('Что-то другое')

   name_file('text.txt')

   name_file('index.html')

def task_3():

   """3)Напишите программу, которая получает номер месяца  

   и выводит соответствующее ему время года или сообщение об ошибке"""

   def monthinteger(n):

       return datetime.date(2018, n, 12).strftime('%B')

   print(monthinteger(3))

   print(monthinteger(1))

def task_4():

   """Напишите программу, которая получает возраст человека (целое число,

   не превышающее 120) и выводит этот возраст со словом «год»,  

   «года» или «лет». Например, «21 год», «22 года», «25 лет». """

   def year(n):

       if n <= 120:

           k = n % 10

           if (n > 9) and (n < 20) or (n > 110) or (k > 4) or (k == 0):

               print("Вам", n, "лет.")

           else:

               if k == 1:

                   print("Вам", n, "год.")

               else:

                   print("Вам", n, "года.")

       else:

           print(False)

   year(21)

   year(22)

   year(25)

if __name__ == "__main__":

   task_1()

   task_2()

   task_3()

   task_4()


Новые вопросы