написать задачу на паскале, но не как пример, который ниже.
Введите с клавиатуры 8 положительных целых чисел. Определите, сколько из них делятся на 3 и при этом заканчиваются на 4. Программа должна вывести одно число: количество чисел, кратных 3 и оканчивающихся на 4.
учитель говорит, что надо НЕ ТАК, а по другому, ибо мы такое не проходили еще:
var b,I:integer;
a:array [1..8] of integer;
begin
writeln('введите числа');
for I:=1 to 8 do
read(a[I]);
b:=0;
for I:=1 to 8 do
if (a[I]mod3=0) and
(a[I]mod10=4) then
b:=b+1;
writeln(b);
readln;
end.
alexanderka:
(((((((((((((((((((((((((((((((((((((((((((((
Ответы на вопрос
Ответил restIess
1
program dlb;
var
x,i,counter : integer;
begin
counter := 0;
for i:= 1 to 8 do
begin
readln(x);
if (x mod 3 = 0) and (x mod 10 = 4) then
counter:= counter + 1;
end;
write(counter);
end.
Новые вопросы
Русский язык,
2 года назад
Английский язык,
2 года назад
Другие предметы,
2 года назад
Литература,
8 лет назад