Информатика, вопрос задал misterred2017 , 9 лет назад

Написать в Паскале
(20 баллов!)

Входные данные

Вводятся целые числа a и b. Гарантируется, что a не превосходит b.

Выходные данные
Выведите все числа на отрезке от a до b, являющиеся полными квадратами. Если таких чисел нет, то ничего выводить не нужно.

Примеры
входные данные
1
1
выходные данные
1
входные данные
2
8
выходные данные
4

Ответы на вопрос

Ответил Sofa404
0
11..3...5..6.55.4.2..4.6
Ответил misterred2017
0
что это? полностью нельзя?
Ответил srzontmp
0
var a,b,i: integer;
begin
  write('a = ');  readln(a);
  write('b = ');  readln(b);
  i:=round(sqrt(a));
  while i*i<a do i:=i+1;
  repeat
    write(i*i,' ');
    i:=i+1;
  until i*i>b;
end.
Новые вопросы