Информатика, вопрос задал enter2287 , 7 лет назад

написать программы,выполняющие данные задачи. Для всех числовых типов данных использовать целочисленный тип.
1.Написать программу, которая считает количество секунд в часе.Пользователь вводит количество часов, а программа в ответ выводит сколько это секунд.
2.Написать программу, которая считает угловой коэффициент прямой, проходящей через точки А и В. Пользователь вводит последовательно координаты точек, а программа выводит угловой коэффициент по формуле k=Ув-Уа/Хв-Ха.
3.Написать программу, которая генерирует случайное трёхзначное число и выводит само число, сумму цифр ,произведение цифр.

Ответы на вопрос

Ответил raf1O5
0

1.                                                        

program raf105;

var hour,sec: integer;

begin

write('Введите количество часов: ');

readln(hour);

sec:= hour*60*60;

writeln('Это ',sec,' сек.');

end.

2.                                                        

program raf105;

var Xa,Ya,Xb,Yb,k: real;

begin

write('Введите координаты первой точки (Х и Y): ');

readln(Xa,Ya);

write('Введите координаты второй точки (Х и Y): ');

readln(Xb,Yb);

k:= (Yb-Ya/Xb-Xa);

writeln('Угловой коэффициент: ',k:0:2);

end.

3.                                                        

program raf105;

var abc,a,b,c,sum,pro: integer;

begin

abc:= random(100,999);

a:= abc div 100;

b:= (abc div 10) mod 10;

c:= abc mod 10;

sum:= a+b+c;

pro:= a*b*c;

writeln('Число ',abc);

writeln('Сумма цифр: ',sum);

writeln('Произведение цифр: ',pro);

end.

                                                         

PascalABC 3.4.2

Ответил enter2287
0
надо было в pyton
Ответил raf1O5
0
Вы не указали язык программирования. Условие задачи неполное.
Новые вопросы