Написать программы для решения задач: 1.Напишите программу, которая в последовательности натуральных чисел определяет максимальное число. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода) Программа должна вывести одно число: максимальное число последовательности. 2. Напишите программу, которая в последовательности из N натуральных чисел определяет максимальное четное число. Программа получает на вход число N- количество чисел, а затем N чисел. Программа должна вывести одно число: максимальное четное число последовательности.
На c++.
Ответы на вопрос
1.
#include <iostream>
#include <algorithm>
#include <vector>
int main()
{
std::vector<unsigned int> arr;
while(true)
{
unsigned int tmp;
std::cin >> tmp;
if(tmp != 0)
arr.push_back(tmp);
else break;
}
std::cout << *std::max_element(arr.cbegin(), arr.cend()) << std::endl;
return 0;
}
2.
#include <iostream>
#include <algorithm>
#include <vector>
#include <functional>
int main()
{
int N;
std::cin >> N;
std::vector<unsigned int> arr(N);
for(auto& i : arr)
std::cin >> i;
std::sort(arr.begin(), arr.end(), std::greater<unsigned int>());
for(auto& i : arr)
{
if(i % 2 == 0)
{
std::cout << i << std::endl;
return 0;
}
}
return 0;
}

