Информатика, вопрос задал Аноним , 8 лет назад

Написать программы для Pascal ABC, срочно!

1.Написать программу организации, заполнения и вывода на экран массива, содержащего среднесуточную температуру воздуха за неделю

2.генерируются 2 случайных натуральных двузначных числа. Найти их сумму, разность большего и меньшего и произведение

3.Написать программу заполнения одномерного массива десятью случайными целыми числами из промежутка [7,25]

Ответы на вопрос

Ответил petyaGavrikov
0
1.
const n=7;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
writeln('Температура за неделю:');
for i:=1 to n do begin
 a[i]:=random(21)-30;
 write(a[i]:5);
 end;
writeln;
end.

Пример:
Температура за неделю:
  -13  -20  -14  -25  -26  -30  -17

2.
var a,b:integer;
begin
a:=random(90)+10;
b:=random(90)+10;
writeln('a = ',a,' b = ',b);
writeln('Сумма = ',a+b);
writeln('Разность = ',abs(a-b));
writeln('Произведение = ',a*b);
end.

Пример:
a = 11 b = 38
Сумма = 49
Разность = 27
Произведение = 418

3.
const n=10;
var a:array[1..n] of integer;
i:integer;
begin
Randomize;
for i:=1 to n do begin
 a[i]:=random(19)+7;
 write(a[i]:3);
 end;
writeln;
end.

Пример:
 24 21 25  7 24 16 18 21 14 25
Ответил Аноним
0
Огромное спасибо!
Новые вопросы