Информатика, вопрос задал pisarevad2101 , 7 лет назад

Написать программу, запрашивающую пять чисел и суммирующию только положительные из них. Значение суммы вывести на экран. Помогите пожалуйста

Ответы на вопрос

Ответил dresqore
0

uses crt;

const n=5;

var a:array[1..n] of integer;

   s,i:integer;

begin

    for i:=1 to n do

    read(a[i]);

    for i:=1 to n do

    write(a[i]:3);

    for i:=1 to n do

    begin

         if (a[i]>0)and(a[i]<>0) then s:=s+a[i];

    end;

    writeln;

    write(s);

end.

Новые вопросы