Написать программу заполняющую строковой массив с размером 5 с клавиатуры , а затем произвести сложение нечётных элементов массива и из их суммы вычесть сумму чётных элементов
Ответы на вопрос
Ответил petrivanov07
0
Хз правильно или нет
uses crt;
var
a: array[1..10] of integer;
s,i: integer;
begin
for i:=1 to 10 do begin
a[i]:=random(51)-25;
write(a[i],'; ');
s:=s+a[i];
end;
writeln;
writeln('Сумма элементов массива: ',s);
end.
Ответил raf1O5
0
program raf105;
var
a: array[1..5] of integer;
x,sum_n,sum_c,res,i: integer;
begin
writeln('Вводите 5 чисел по очереди');
for i:=1 to 5 do
begin
readln(x);
if (x mod 2 = 0) and (x <> 0)
then sum_c:= sum_c + x;
if x mod 2 <> 0
then sum_n:= sum_n + x;
end;
writeln('Вывод: ',sum_n-sum_c);
end.
PascalABC 3.4.2
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Математика,
7 лет назад
История,
7 лет назад
Математика,
9 лет назад