Написать программу, заполняющую массив из 30 случайными числами [0..80].
Вывести массив.
Определить в этом массиве сумму чисел, кратных 3
Определить количество отрицательных чисел.
Определить в этом массиве номер элемента, равного 0
Ответы на вопрос
Ответ:
program ExampleNNNN;
uses
SysUtils; // зависит от того где объявлено IntToStr в вашей версии Паскаля
var
a: array [1..30] of Integer;
i, c, s: Integer;
e: string;
begin
Randomize;
for i := Low (a) to High (a) do begin
a [i] := Random (81);
Write (a [i], ' ');
end;
s := 0;
c := 0;
e := '';
for i := Low (a) to High (a) do begin
if a [i] mod 3 = 0 then
s := s + a [i];
if a [i] < 0 then
Inc (c);
if a [i] = 0 then
e := e + IntToStr (a [i]) + ', ';
end;
WriteLn;
WriteLn ('Сумма чисел кратных 3 = ', s);
WriteLn ('Количество отрицательных чисел = ', c);
if e <> '' then
WriteLn ('Номера элементов = 0: ', e)
else
WriteLn ('Элементов равных нулю нет', e);
ReadLn;
end.
Объяснение:
не понятно какая размерность массива и какими числами его заполнять. если что, это меняется в этих операторах:
a: array [1..30] of Integer;
a [i] := Random (81);