Написать программу, заполняющую массив из 13 чисел [-10..10].
1. Вывести массив.
2. Отсортировать массив по возрастанию. Вывести
3. Определить в этом массиве сумму всех отрицательных чисел.
4. Уменьшить на 5 все элементы массива и вывести измен.мас
Ответы на вопрос
Ответил gfhjkmgfhjkm20
1
Ответ:
program Massiv_sort;
var a:array [1..13] of Integer;
i,so,j,v:Integer;
begin
write ('1. Массив ');
for i:=1 to 13 do
begin
a[i]:=random(21)-10;
if a[i]<0 then so:=so+a[i];
write (a[i], ' ')
end;
WriteLn;
for i:=1 to 12 do
for j:=1 to 13-i do
if a[j]>a[j+1] then
begin
v:=a[j];
a[j]:=a[j+1];
a[j+1]:=v
end;
write ('2. Массив ');
for i:=1 to 13 do write (a[i], ' ');
WriteLn;
WriteLn('3. Сумма отрицательных элементов ',so);
write ('4. Массив ');
for i:=1 to 13 do
begin
a[i]:=a[i]-5;
write (a[i], ' ')
end;
end.
Новые вопросы
Физика,
1 год назад
Информатика,
1 год назад
Математика,
1 год назад
Английский язык,
1 год назад
История,
7 лет назад
Алгебра,
7 лет назад