Информатика, вопрос задал ksusamakinen3 , 6 лет назад

Написать программу, выводящую числа от 1 до 30 и подсчитать сумму чисел оканчивающихся на 5

Ответы на вопрос

Ответил MrSolution
0

Ответ:

(см. объяснение)

Объяснение:

В современном паскале вывести все числа от 1 до 30 в порядке возрастания можно так:

##

(1..30).print;

Если подсчет предполагается лобовой, то второй пункт может быть решен так:

##

(1..30).Count(x->x mod 5 = 0).print;

Таким образом, мы видим, что возможности PascalABC.NET достаточно велики.

Можно даже написать что-то такое, если хотите (язык вы не указали):

#!/bin/bash

awk 'BEGIN {

 cnt = 0;

 for (i = 1; i <= 30; ++i) {

   if (i % 5 == 0) {

     ++cnt;

   }

   printf("%d ", i);

 }

 printf("\n%d", cnt);

}'

Задание выполнено!

Новые вопросы