Информатика, вопрос задал Dertyc412 , 6 лет назад

Написать программу вывода значений с 500 до 0 на экран . срочно !!!!!!!!!!!!!
даю 100 баллов!!!!!!!!!

Ответы на вопрос

Ответил govnoola
2

Ответ:

На c++

Объяснение:

#include<iostream>

#include<iomanip

#include<math.h>

#include"stdafx.h"

using namespace std;

  int main()

{    

double s, x, a, b, h;    

int k, i;      

cout << "Vvedite a, b, h, k:" << endl;    

cin >> a >> b >> h >> k;    // Ввод значений: 0.1 1 0.1 20

x = a;  

do  // Начало цикла по  x    

{        

s = 2;  // Начальное значение при k=0        

for (i = 1; i <= k; i++)          // Вычисление суммы            

s += 2 * pow(x, i) / pow(cos(x), i);         cout << setw(15) << x << setw(15) << s << endl;      // Вывод таблицы         x += h; // Изменение значения x на величину шага h     } while (x <= b + h / 2);       // Проверка условия продолжения цикла по x       cout << endl;   // Переход на новую строку       return 0; }

Новые вопросы