Информатика, вопрос задал polina78177 , 2 года назад

Написать программу, вычитающую площадь ромба если d1=8 a d2=6


boberon: Хоть язык программирования укажи что ли...
polina78177: а что это?
businessXdak: Я сейчас уже делаю)
boberon: Охххх

Ответы на вопрос

Ответил businessXdak
1

Решение

2 решения может быть, возьми нужное.

1. Где переменные нужно водить самому

Var d1,d2:integer;

s:real;

begin

write('D1 = ');

readln(d1);

write('D2 = ');

readln(d2);

s:=1/2*d1*d2;

write('Площадь ромба равна: ',s);

end.

2. Где переменные уже ведены в программу

Var d1,d2:integer;

s:real;

begin

d1:=8;

d2:=6;

s:=1/2*d1*d2;

write('Площадь ромба равна: ',s);

end.


businessXdak: Тебе скорее всего нужен 2 вариант
boberon: Эмм... Откуда тут корни, разность и pi? Это ж ромб!
businessXdak: S:=1/2*d1*d2;
businessXdak: Изменил, смотри)
boberon: Ну я бы сделал d1*d2/2, объявлял d1, d2 как real и заменил последний write на writeln. В остальном выглядит нормально.
polina78177: угу,благодарю ^-^
Новые вопросы