Написать программу,вычисляющую значение функции: ln(x)*sin(x)-46, если x<-6; (51/e^x)*(57/x), если -6<=x<-4; x+cos(2*x), если -4<=x
В паскале
Приложения:

Ответы на вопрос
Ответил Аноним
0
PascalABC.NET 3.4.2, сборка 1797 от 22.09.2018
Внимание! Если программа не работает, обновите версию!
№1
begin
var x := ReadReal('x=');
var y: real;
if x < -6 then y := Ln(x) * Sin(x) - 46
else
if x < -4 then y := 51 / Exp(x) * 57 / x
else y := x + Cos(2 * x);
Println('y=', y)
end.
№2
begin
var (a, b, h) := (-8.0, -2.0, 0.3);
var x := a;
var y: real;
while x <= b + h / 2 do
begin
if x < -6 then y := Ln(x) * Sin(x) - 46
else
if x < -4 then y := 51 / Exp(x) * 57 / x
else y := x + Cos(2 * x);
Writeln(x:4:1, y:20:9);
x += h
end
end.
Приложения:

Ответил Аноним
0
Для "Спасибо" Вы уже кликнули сердечко, этого вполне достаточно.
Ответил AminOlimy
0
а не могли бы вы еще одну такую задачку решить?
Ответил AminOlimy
0
тут что то ошибку nan nan выдает
Ответил AminOlimy
0
у вас там после 5.9 цифры а тут токо восемь стоит
Ответил Аноним
0
Я же написал, что логарифм не существует для отрицательных х. Вы что, математику тоже не знаете, как и информатику? NaN - это Not a Number - не числовое значение. Потому что нельзя вычислить.
Новые вопросы
Русский язык,
2 года назад
Литература,
7 лет назад
Математика,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад