Информатика, вопрос задал nt4449184 , 6 лет назад

написать программу вычисляющую произведение четных элементов массива D, размерностью 15, Элементы массива-числа промежутка [0, 50]​


nt4449184: в паскале
limondimon261: нет c++
limondimon261: извини
limondimon261: ты просто не указал на каком языке
nt4449184: блин, ну ладно=(
limondimon261: удачи пока

Ответы на вопрос

Ответил limondimon261
0

include<vector>

int main()

{

int mas[15] = [сюда вводишь массив через запятую];

vector<int> mass;

for(int i =0;i<15;i++){

if (mas[i]%2)

mass.push_back(mas[i])

}

return 0;

}


nt4449184: это в паскале?
Ответил vimmortal2
0

Программа:

Pascal:

var

 D: array[1..15] of integer;

 pr, i: integer;

begin

 pr := 1;

 for i := 1 to 15 do begin

   D[i] := random(0, 50);

   if D[i] mod 2 = 0 then pr *= D[i];

 end;

 writeln(D, #10, 'Произведение чётных элементов: ', pr);

end.


nt4449184: спасибо большое!!
Новые вопросы