Написать программу вычисления значения выражения:
sin2*sin4*sin6*…*sin2N при заданном N (цикл «до»)
mnv1962:
язык какой?
Ответы на вопрос
Ответил mnv1962
2
var
n:integer;
x,p:real;
begin
x:=2;p:=1;
writeln('N?');
readln(n);
repeat
p:=p*Sin(x);
x:=x+2;
until x>n*2;
writeln('p: ',p:4:2);
end.
n:integer;
x,p:real;
begin
x:=2;p:=1;
writeln('N?');
readln(n);
repeat
p:=p*Sin(x);
x:=x+2;
until x>n*2;
writeln('p: ',p:4:2);
end.
Новые вопросы