Информатика, вопрос задал Acril , 10 лет назад

Написать программу вычисления величины


             B = m(m-1)(m-2) …  (m-(n-1))
,


      где 
m, n заданы
 (m>n, m,n – натуральны
числа).

Ответы на вопрос

Ответил JustPeople
0
VAR
   n, m, ans, i: UInt64;
BEGIN
   Read(m, n);

   ans := m;
   For i := 1 to (n-1) do
      ans := ans*(m - i);

   Write(ans);
END.
Новые вопросы