Информатика, вопрос задал Bukabukachagava , 8 лет назад

Написать программу вычисления среднеарифметического последовательно вводимых целых чисел, пропуская отрицательные, с окончанием по вводу признака конца.

Ответы на вопрос

Ответил Елизавета123455
0
var a,b,k,s:integer;
 Begin 
writeln ('Сколько всего будет чисел?');
readln (a);
writeln ('Вводите числа по одному через enter');
for b:=1 to a do
begin
readln (k);
 if k>0 then S:=S+k;
end;
writeln(S/a); 
end.
Новые вопросы