Информатика, вопрос задал mirojulia23 , 8 лет назад

Написать программу вычисления функции F=( n+5)! – n . Значение n вводим с клавиатуры

1) Построение математической модели - представление ее в виде формул, уравнений, соотношений, которые могут быть реализованы в компьютере.
2) Алгоритмизация - построение алгоритма. блок-схемы
3) Написание задачи на языке программирования.
Программа должна быть универсальной (не зависящей от конкретного набора данных). Необходимо предусмотреть контроль вводимых данных. Необходимо повысить эффективность программы, т. е. уменьшить количество выполняемых операций и время работы программы.
Помогите, пожалуйста!

Ответы на вопрос

Ответил OnlineFox
0
В комментарии к этой записи выложу остальное, т.к. время на ответ ограничено.
Приложения:
Ответил OnlineFox
0
Сейчас выложу 3
Ответил OnlineFox
0
Вот 3: http://uploads.ru/nMaKs.png
Ответил OnlineFox
0
Вот 1: Begin ---> If X1<0 then Writeln('Число отрицательное'); else Writeln('Число положительное'); ---> End.
Ответил OnlineFox
0
Это было 2*
Ответил OnlineFox
0
Вот 1: X - Высота, Y - Ширина. С помощью этих двух значений можно построить квадрат, прямоугольник и треугольник.
Новые вопросы