Информатика, вопрос задал anoralex , 7 лет назад

написать программу вычисления f(x)в соответствии с ее областью определения на любом из этих языков: c++, java, pascal

Приложения:

Ответы на вопрос

Ответил simbion0
0

// C++

#include <iostream>

#include <cmath>


int main()

{

double x, a;

std::cin >> x >> a;


double f = std::sqrt(x / a + a / x) + std::log(std::sin(x) / std::cos(2 * x));


std::cout << f << std::endl;


return 0;

}

Ответил Аноним
0
В условии написано "в соответствии с областью ее определения". Вы просто проигнорировали эту фразу.
Ответил Аноним
0
Собственно, лично мне все равно. Это комментарий для автора вопроса - повод задуматься.
Ответил simbion0
0
Хорошо, тогда почему в условии ничего не сказано про шаг для области?
Ответил Аноним
0
Какой шаг? Задаются a, x и вычисляется значение функции.
Ответил Аноним
0
Это же не задача табуляции на интервале.
Ответил Аноним
0

PascalABC.NET 3.4.2, сборка 1857 от 05.11.2018

Внимание! Если программа не работает, обновите версию!

begin

 var F: (real,real) -> real :=

     (a, x) -> Sqrt(x / a + a / x) + Ln(Sin(x) / Cos(2 * x));

 var (a, x) := ReadReal2('Введите a, x:');

 f(a, x).Println

end.

Примеры

Введите a, x: 3.5 0.24

2.51096182288121

Введите a, x: 5 2

NaN - при невозможности вычислить функцию

Новые вопросы