Информатика, вопрос задал Sergei1906 , 10 лет назад

Написать программу Вводя числа с клавиатуры без ограничения их количества (конец ввода - число 0), найти сумму положительных и произведение отрицательных чисел .СРОЧНО.

Ответы на вопрос

Ответил ИгорёКо
0

program c1;
var
a,b,n:longint;
Begin
a:=0;
writeln('Вводи числа sergei1906');

repeat
read(n);
if n>0 then b:=b+n;
if n<0 then a:=a*n;
until n=0;
Writeln('Сумма положительных чисел: ',b);
Writeln('Произведение отрицательных чисел: ',a);
End.

Новые вопросы