Информатика, вопрос задал vovaakovlev9 , 1 год назад

Написать программу возведение произвольного числа в произвольную степень с помощью циклических конструкций. ​

Ответы на вопрос

Ответил voronovsasa996
0

Ответ:

#include <stdio.h>

int main() {

   double base, exponent, result = 1;

   int i;

   printf("Введите число: ");

   scanf("%lf", &base);

   printf("Введите степень: ");

   scanf("%lf", &exponent);

   // Вычисление

   for (i = 1; i <= exponent; i++) {

       result *= base;

   }

   printf("%.2lf в степени %.2lf = %.2lf", base, exponent, result);

   return 0;

}

Объяснение:

Новые вопросы