Написать программу, ведущую учет очков, набранных каждой командой при игре в баскетбол. Количество очков, полученных командами в ходе игры, может быть равно 1, 2 или 3. После окончания игры выдать итоговое сообщение и указать номер команды-победительницы. Окончание игры условно моделировать вводом количества очков, равного нулю. На паскаль
Ответы на вопрос
Ответил HRAshton
0
var
commands: array [1..2] of byte;
buf: string;
begin
writeln('Формат ввода: (№ комманды)(пробел)(очки)');
writeln('Например: 1 3');
writeln('№ О');
repeat
readln(buf);
if buf = '0' then break;
commands[integer.Parse(buf[1])] += byte.Parse(buf[3]);
until false;
writeln(String.Format('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2] ? 1 : 2, max(commands[1], commands[2])));
end.
commands: array [1..2] of byte;
buf: string;
begin
writeln('Формат ввода: (№ комманды)(пробел)(очки)');
writeln('Например: 1 3');
writeln('№ О');
repeat
readln(buf);
if buf = '0' then break;
commands[integer.Parse(buf[1])] += byte.Parse(buf[3]);
until false;
writeln(String.Format('Команда {0} победила во счётом {1} очк.', commands[1] > commands[2] ? 1 : 2, max(commands[1], commands[2])));
end.
Ответил Аноним
0
Полный код не влез, в 2 комента вставил
Новые вопросы
Английский язык,
2 года назад
Математика,
2 года назад
Алгебра,
9 лет назад
Алгебра,
9 лет назад
Математика,
10 лет назад