Информатика, вопрос задал Fedorova61 , 8 лет назад

Написать программу в С++. Задан двумерный массив Y из 7-и строк и 3-х столбцов. Составить программу, которая вычисляет значение суммы произведений элементов строк

Ответы на вопрос

Ответил Maksim2009rus
0
#define N 7
#define M 3
#include <iostream>
using namespace std;
int main() {   
    float Y[N][M];
    // Ввод данных
    for (int i = 0; i < N; i++)
        for (int j = 0; j < M; j++)
            cin >> Y[i][j];

    float sum = 0, prod = 0;
    for (int i = 0; i < N; i++) {
        prod = 1;
        for (int j = 0; j < M; j++) {
            prod *= Y[i][j];
        }
        sum += prod;
    }
    cout << "Sum: " << sum << ".n";
    return 0;
}

Новые вопросы