Информатика, вопрос задал UAGamesTactics , 8 лет назад

Написать программу в С++
Проверить входит ли в заданную последовательность символов каждая из букв слова key

Ответы на вопрос

Ответил MaxLevs
0
Кодяра ниже
\\\\\\\\\\\\\\\\\\\
#include <iostream>#include <string>using namespace std;int main() { setlocale(LC_ALL, "Russian"); string key = "key", buffer; cout << "Введите последовательность: "; cin >> buffer; bool *bitmap = new bool[key.length()]; for (int j = 0; j < key.length(); ++j) bitmap[j] = false; for(int i = 0; i < buffer.length(); ++i) for(int j = 0; j < key.length(); ++j) if (buffer[i] == key[j]) bitmap[j] = true; for (int j = 0; j < key.length(); ++j){ cout << """ << key[j] << """; if (bitmap[j]) cout << " есть!" << endl; else cout << " нет!" << endl; } system("pause"); return 0;}
\\\\\\\\\\\\\\\\\\\\
Кодяра выше
Новые вопросы