Написать программу в С++
Описать функцию Otr(Ax,Bx,Ay,By) вещественного типа находящую длину отрезка AB на плоскости по координатам его концов |AB|=sqrt((Ax-Bx)^2+(Ay-By)^2 )(Ax,Ay,Bx,By)- вещественны параметры) с помощью этой функции найти длины отрезков AB,AC,AD, если с клавиатуры заданы координаты точек, A,B,C,D.
Ответы на вопрос
Ответил Аноним
0
#include <iostream>
#include <cmath>
using namespace std;
double Otr(double Ax, double Bx, double Ay, double By) {
return sqrt((Bx - Ax)*(Bx - Ax) + (By - Ay)*(By - Ay));
}
int main() {
double Ax, Ay, Bx, By, Cx, Cy, Dx, Dy;
cin >> Ax >> Ay >> Bx >> By >> Cx >> Cy >> Dx >> Dy;
cout << "|AB|=" << Otr(Ax, Bx, Ay, By) << endl;
cout << "|AC|=" << Otr(Ax, Cx, Ay, Cy) << endl;
cout << "|AD|=" << Otr(Ax, Dx, Ay, Dy) << endl;
return 0;
}
Приложения:

Ответил Аноним
0
Дважды-то зачем? ))) Я же писал, что с Паскалем эти языки по сути схожи. Да об этом и сам Дохлый Страус писал.
Ответил Денис88
0
Ну теперь вижу, что действительно похожи!)
Ответил Аноним
0
А до этих пор Вы не верили словам создателя С++ ?
Ответил Денис88
0
Доверяй, но проверяй, как говорится.
А так знал это, но на практике не встречался
А так знал это, но на практике не встречался
Ответил Аноним
0
Вот поэтому меня всегда удивляют просьбы переписать с Паскаля в С++ и наоборот.
Новые вопросы
Русский язык,
2 года назад
Математика,
7 лет назад
Алгебра,
7 лет назад
Математика,
9 лет назад
Математика,
9 лет назад