Информатика, вопрос задал UAGamesTactics , 8 лет назад

Написать программу в С++ Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая это самое число. Например, число 6 является совершенным (1+2+3 = 6). Найти все совершенные числа, меньшие 100 000.

Ответы на вопрос

Ответил petyaGavrikov
0
#include <iostream>
using namespace std;

int main(){
    int s;
    for (int i=2; i<=100000; i++){
    s = 1;
    for (int j=2; j<=i/2; j++)
    if (i % j == 0) s+=j;
    if (s == i)
    cout << i << " ";
    }
    return 0;
}

Результат:
6 28 496 8128
Новые вопросы