Информатика, вопрос задал mitygina , 1 год назад

Написать программу,в с ++ , которая бы по введенному номеру единицы измерения(1-килограмм, 2-миллиграмм, 3-грамм, 4-тонна, 5-центнер) и масса M выдавала бы соответствующее значение массы в килограммах.Пожалуйста помогите в с ++

Ответы на вопрос

Ответил FilNez
1

#include <iostream>

using namespace std;

int main() {

int unit, m;

cin>>unit>>m;

if (unit == 2) {

m*=1000000;

}

else if (unit == 3) {

m*=1000;

}

else if ( unit == 4 ) {

m/=1000;

}

else if ( unit == 5 ) {

m/=100;

}

cout<<m;

}

Новые вопросы
Алгебра, 1 год назад