Информатика, вопрос задал Кристина3214 , 1 год назад

Написать программу в Python, которая создает папку "Личные дела", и создает в нем 3 папки "Информация", "Работы", "Разное". В папке Личные дела создать файл "Инфо.txt" содержащий номер телефона.

Ответы на вопрос

Ответил FroDK
1

Ответ:

import os

def mkdir_creator():

   path = os.getcwd()+'/Личные дела'

   try:

       os.mkdir(path)

       os.mkdir(path+'/Информация')

       os.mkdir(path+'/Работы')

       os.mkdir(path+'/Разное')

       with open(path+'/Инфо.txt', 'w') as f:

           f.write('89990102233')

   except OSError:

       print ("Создать директории не удалось")

   else:

       print ("Успешно созданы директории")

mkdir_creator()

Объяснение:

Python 3.7

tg = Fr0DK

Новые вопросы