Информатика, вопрос задал 2SAnastasiAS2 , 2 года назад

написать программу в питоне. плииизз. очень срочно

Приложения:

Аноним: 0 100 200 300 400 500 600 700 800 900 1000
1.290 1.274 1.258 1.243 1.227 1.212 1.197 1.182 1.167 1.153 1.138
Аноним: в таком виде пойдет?
2SAnastasiAS2: надо написать программу, я же не покажу просто числа
Аноним: я имею ввиду таблица в таком виде будет нормально? код я написал
Аноним: это результат работы кода
2SAnastasiAS2: ну наверно да
2SAnastasiAS2: нам не говорили как она должна выглядеть

Ответы на вопрос

Ответил Аноним
0

Ответ:

from math import exp

p0 = 1.29

z = 1.25 * 10 ** -4

dict = {h: p0 * exp(-h * z) for h in range(0, 1001, 100)}

for h, p in dict.items():

   print(f'{h:5} {p}')

Объяснение:


Аноним: вместо подчеркивания tab
2SAnastasiAS2: h:5 что это
2SAnastasiAS2: мы вроде не проходили вот такие скобки {} их никак нельзя заменить?
Аноним: можно
__ print(h, p)
Аноним: h:5 - это выравнивание по левому краю, чтобы вид таблицы был )
Аноним: f'{h:5} {p}' - это форматирование вывода строки
2SAnastasiAS2: у меня ещё немного заданий осталось по питону
Аноним: давай, попробую помочь ))
2SAnastasiAS2: в профиле, если не ошибаюсь
Аноним: ща гляну
Новые вопросы