написать программу в паскале . вводим два числа. компьютер должен вывести квадратное уравнение,корнями которого являются эти два числа. (использоват теорему виета)
Ответы на вопрос
Ответил Света19999
0
var x1,x2,p,b:real;
begin
readln(x1,x2);{Вводим два числа}
p:=x1+x2;{Вычисляем значение коэффициента при х}
b:=x1*x2;{Вычисляем значение свободного слагаемого}
if p>0 then{Проверка на знак полученных значений и вывод уравнения, как проще сделать со знаком, увы не знаю}
begin
if b>0 then
writeln('x^2-',p,'x+',b,'=0')
else
writeln('x^2-',p,'x-',abs(b),'=0');
end
else
begin
if b>0 then
writeln('x^2+',abs(p),'x+',b,'=0')
else
writeln('x^2+',abs(p),'x-',abs(b),'=0');
end;
end.
begin
readln(x1,x2);{Вводим два числа}
p:=x1+x2;{Вычисляем значение коэффициента при х}
b:=x1*x2;{Вычисляем значение свободного слагаемого}
if p>0 then{Проверка на знак полученных значений и вывод уравнения, как проще сделать со знаком, увы не знаю}
begin
if b>0 then
writeln('x^2-',p,'x+',b,'=0')
else
writeln('x^2-',p,'x-',abs(b),'=0');
end
else
begin
if b>0 then
writeln('x^2+',abs(p),'x+',b,'=0')
else
writeln('x^2+',abs(p),'x-',abs(b),'=0');
end;
end.
Новые вопросы