Информатика, вопрос задал mishavolkov29 , 2 года назад

Написать программу в Паскале пожалуйста, очень надо)
Найти среднее арифметическое максимального и минимального элементов массива

Ответы на вопрос

Ответил UBSilver
0

Ответ:

См объяснение + скриншот.

Объяснение:

program prog;

var

  a:array[1..5] of integer;

  max,min,i:integer;

  srednee:real;

begin

writeln('Zapolnim massiv iz 5 elementov:');

for i:=1 to 5 do readln(a[i]);

max:=a[1];

min:=a[1];

for i:=2 to 5 do begin

 if max<a[i] then max:=a[i];

end;

for i:=2 to 5 do begin

 if min>a[i] then min:=a[i];

end;

writeln('max=',max);

writeln('min=',min);

srednee:=(max+min)/2;

writeln('srednee arifm=',srednee);

end.

Приложения:
Новые вопросы