Информатика, вопрос задал shura72 , 8 лет назад

Написать программу в паскале Pascal АВС
Задания для самостоятельного решения

1) Известно количество символов в каждой строке, количество строк на странице. Написать про-грамму, вычисляющую число символов на странице.
2) Составить программу, запрашивающую при помощи операторов ввода-вывода: название куп-ленного товара, количество и цену за единицу. После вычислений и очистки экрана выдаются следующие сообщения: название товара и его общая стоимость.
3) Известно оклад сотрудника, количество отработанных дней и число рабочих дней в месяце. Составить программу нахождения заработной платы сотрудника, с учетом вычетов подоходного налога (13%) и пенсионного налога (1%).

Ответы на вопрос

Ответил Аноним
0
var
  cl,lp:integer;
begin
  Write('Количество символов в строке- '); Read(cl);
  Write('Количество строк на странице- '); Read(lp);
  Writeln('Количество символов на странице: ',cl*lp)
end.
 
Пример
Количество символов в строке- 68
Количество строк на странице- 45
Количество символов на странице: 3060

uses Crt;
var
  nt:string; { наименование товара }
  kt:real; { количество товара }
  ct:real; { цена товара за единицу }
begin
  Write('Наименование товара- '); Readln(nt);
  Write('Количество товара- '); Read(kt);
  Write('Цена за единицу товара- '); Read(ct);
  ClrScr;
  Writeln(nt,' - ',ct*kt:0:2)
end. 
 
Результаты работы программы даны во вложениях

const
  podn=0.13; { подоходный налог }
  pensf=0.01; { в Пенсионный фонд }
var
  os:real; { оклад сотрудника }
  nd:integer; { количество отработанных дней }
  nr:integer; { количество рабочих дней в месяце }
  nach:real; { начислено }
  sp:real; { сумма подоходного налога }
  spf:real; { сумма отчислений в ПФ }
  nzp:real; { итого начислений на зарплату }
  svyd:real; { сумма к выдаче }
begin
  Write('Оклад, руб- '); Read(os);
  Write('Отработано дней- '); Read(nd);
  Write('Рабочих дней- '); Read(nr);
  nach:=os*nd/nr; { может получиться нецелое число }
  { округлим до сотых долей }
  nach:=Round(nach*100)/100;
  sp:=nach*podn; sp:=Round(sp*100)/100;
  spf:=nach*pensf; spf:=Round(spf*100)/100;
  nzp:=sp+spf;
  svyd:=nach-nzp;
  Writeln('Начислено, руб:         ',nach:0:2);
  Writeln('Подоходный налог, руб:  ',sp:0:2);
  Writeln('В Пенсионный фонд, руб: ',spf:0:2);
  Writeln('Итого налогов, руб:     ',nzp:0:2);
  Writeln('К выдаче, руб:          ',svyd:0:2)
end.

Пример
Оклад, руб- 46420
Отработано дней- 19
Рабочих дней- 22
Начислено, руб:         40090.00
Подоходный налог, руб:  5211.70
В Пенсионный фонд, руб: 400.90
Итого налогов, руб:     5612.60
К выдаче, руб:          34477.40
Приложения:
Новые вопросы