Информатика, вопрос задал 6603673 , 9 лет назад

Написать программу в паскале.
на вход подается х, на выход y = 5*x если x>0 и y = х*х иначе

X и Y целые числа.

Ответы на вопрос

Ответил infor5
0
uses crt;
var x,y:integer;
begin
write('введите х'); read(x);
if x>0 then y:=5*x else y:=x*x;
write('y=', y);
readkey;
end.
Ответил 6603673
0
readkey?
Ответил 6603673
0
А не readln?
Ответил infor5
0
первую строку и предпоследнюю для версии паскаль ABC можно убрать, они выполняют задержку экрана..
Ответил 6603673
0
Нужно писать readln?
Ответил infor5
0
можно писать readln (курсор в этом случае переходит на следующую строку), но можно read (курсор остается на строке, где напечатано будет 'введите x')
Ответил Аноним
0
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var x:=ReadInteger('x=');
  Writeln('y=',x>0?5*x:x*x)
end.

Тестовое решение
x= 4
y=20

x= -4
y=16
Новые вопросы