написать программу в паскале котрая расставляет три числа в порядке возрастания
Ответы на вопрос
Ответил JOON1K
0
program ttt;
var i,j,a,b,c:integer;
begin
readln(a);
readln(b);
readln(c);
if (a>b) then
if (a>c) then
begin
write(a);
if (b>c) then begin write(b);write(c) end; else begin write(c); write(b);end
end; else
if (b>c) then begin write (b); if(a>c)then begin write(a); write(c);end; else begin write(c); write(a);end; end;
else begin write(c); if(a>b) then begin write(a);write(b)end; else begin write(b); write(a); end;end;
end;
неоптимальный, но понятный алгоритм.
а в другом случае можноо оптимизировать.. как- подумай -;)
Новые вопросы