Написать программу в Паскале, которая вычислит все двузначные числа,сумма цифр которых равна 12. Только , как можно проще. Алгоритм вычисления пожалуйста пришлите.
Ответы на вопрос
Ответил m0nclous
0
Var
a,a1,a2:integer;
Begin a:=10;
Write('Двузначные числа, сумма цифр которого равна 12: ');
while a<100 do
begin
a1:=a mod 10;
a2:=a div 10;
if (a1+a2)=12 then write(a,', ');
a:=a+1;
end;
End.
a,a1,a2:integer;
Begin a:=10;
Write('Двузначные числа, сумма цифр которого равна 12: ');
while a<100 do
begin
a1:=a mod 10;
a2:=a div 10;
if (a1+a2)=12 then write(a,', ');
a:=a+1;
end;
End.
Ответил m0nclous
0
пояснить действия?
Ответил Pastelek
0
Да
Ответил Pastelek
0
Хотя, нет не надо
Ответил m0nclous
0
ок, я упростил программу. Убрал не нужную переменную
Ответил Pastelek
0
Спасибо
Новые вопросы