Написать программу (В ПАСКАЛЕ) , которая вводит с клавиатуры 5 дробных чисел и вычисляет их среднее арифметическое.Рекомендуемый вид экрана во время работы программы приведен ниже. Данные, введенные пользователем выделены полужирным шрифтом.Вычисление среднего арифметического последовательности дробных чисел. После ввода каждого числа нажимайте .
-> 5.4
->7.8
-> 3.0
-> 1.5
-> 2.3
Среднее арифмитическое введенной последовательности: 4. 00
Для завершения работы программы нажмите < Enter>.
Ответы на вопрос
Ответил arseney0cs
0
var i: integer;
var a : array[1..5] of real;
begin
for i in [1..5] do
begin
write('->');
readln(a[i]);
end;
writeln((a[1]+a[2]+a[3]+a[4]+a[5])/5:0:2);
end.
Ответил HumphreyVanVeiden
0
program dgh;
var
a,b: real;
i: integer;
Begin
b:=0;
for i:=1 to 5 do
begin
Write ('->'); readln (a);
b:=b+a;
end;
write('среднее арифметическое введенной последовательности:');
write (b/5:0:2);
Readln;
end.
Новые вопросы
Русский язык,
2 года назад
Українська література,
2 года назад
Алгебра,
7 лет назад
Математика,
7 лет назад
Математика,
9 лет назад