Написать программу в Паскале, которая проверяет, принадлежит ли точка(х, у) закрашеной области

Ответы на вопрос
Ответ:
program z1;
var R,x,y:real;
begin
write('R = ');
readln(R);
write('x = ');
readln(x);
write('y = ');
readln(y);
if (x*y>=0) and (abs(y)>=abs(x)) and (sqr(x)+sqr(y)<=R*R) then write ('Точка принадлежит закрашенной области')
else write ('Точка не принадлежит закрашенной области')
end.
Объяснение:
Получение данных для программы с пояснениями (write - вывод на экран, readln - ввод данных пользователем):
write('R = ');
readln(R);
write('x = ');
readln(x);
write('y = ');
readln(y);
Проверка условия принадлежности точки и вывод результатов проверки в зависимости от результатов проверки (полный условный оператор - if ... then ... else, составное условие - (x*y>=0) and (abs(y)>=abs(x)) and (sqr(x)+sqr(y)<=R*R)):
if (x*y>=0) and (abs(y)>=abs(x)) and (sqr(x)+sqr(y)<=R*R) then write ('Точка принадлежит закрашенной области')
else write ('Точка не принадлежит закрашенной области')