Написать программу в Паскале, которая прибавляет к 1 число 7 до тех пор, пока полученная сумма не превысит max число, введенное с клавиатуры. После каждого действия вывести полученную сумму, если она меньше max числа
Ответы на вопрос
Ответил petyaGavrikov
0
var max,s:integer;
begin
write('max = ');
readln(max);
s:=1;
while s<=max do
begin
write(s,' ');
s:=s+7;
end;
writeln;
end.
Пример:
max = 40
1 8 15 22 29 36
begin
write('max = ');
readln(max);
s:=1;
while s<=max do
begin
write(s,' ');
s:=s+7;
end;
writeln;
end.
Пример:
max = 40
1 8 15 22 29 36
Новые вопросы