Написать программу в паскале, которая после введенного с клавиатуры числа(в диапазоне от 1 до 99), обозначающий денежную единицу, дописывал слово "Копейка". Например ,5 копеек,41 копейка и тд.
Вот мои попытки создать программу:
Program Kopeika;
Var a:integer;
begin
Writeln('Vvedite chislo');
Readln(a);
Case a of
'1,21,31,41,51,61,71,81,91': a:='Kopeika ';
'2..4,22..24,32..34,42..44,52..54,62..64,72..74,82..84,92..94': a:='Kopeiki ';
'5..20,25..30,35..40,45..50,55..60,65..70,75..80,85..90,95..99': a:=' Kopeek';
end;
Readln;
end.
Ответы на вопрос
Ответил MaxKon2011
0
По идее нужен цикл, который будет перебирать значения case. Я больше знаю c#, но могу посоветовать только поработать с циклами, т.к не знаю как с ними обстоит дело в паскале.
Ответил MaxKon2011
0
А нет, видимо ты в конце не составил код, чтобы это число, которое получилось - выводилось, а может я и не понимаю в паскале)
Ответил Royal21
0
Исправленный вариант:
program Kopeika;
var
a: integer;
begin
Writeln('Vvedite chislo');
Readln(a);
case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: write(a, ' kopeika');
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: write(a, ' kopeiki');
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..99: write(a, ' kopeek');
end;
Readln;
end.
program Kopeika;
var
a: integer;
begin
Writeln('Vvedite chislo');
Readln(a);
case a of
1, 21, 31, 41, 51, 61, 71, 81, 91: write(a, ' kopeika');
2..4, 22..24, 32..34, 42..44, 52..54, 62..64, 72..74, 82..84, 92..94: write(a, ' kopeiki');
5..20, 25..30, 35..40, 45..50, 55..60, 65..70, 75..80, 85..90, 95..99: write(a, ' kopeek');
end;
Readln;
end.
Новые вопросы