Информатика, вопрос задал lolakekk , 8 лет назад

Написать программу в Паскале, которая определяет сумму натуральных чисел кратных 3 и оканчивающихся на 6. Последнее число последовательности 0. Количество чисел не превышает 1000. Количество введённых чисел неизвестно.

Ответы на вопрос

Ответил moboqe
0
uses crt;
var  n, i, s: integer; 
a: array [1..1000] of integer;
begin  writeln('Введите количество чисел последовательности');
read(n); 
s := 0; 
writeln('Введите числа'); 
for i := 1 to n do 
begin  
read(a[i]);   
a[n] := 0; 
end; 
writeln(); 
for i := 1 to n do   
write(a[i], ' '); 
writeln(); 
for i := 1 to n do   
s := s + a[i]; 
writeln('Сумма=', s);
end.
Новые вопросы