Написать программу в паскале: Даны целое n>0 и последовательность из n вещественных чисел, среди которых есть хотя бы одно отрицательное число. Найти величину наибольшего среди отрицательных чисел этой последовательности.
Ответы на вопрос
Ответил Аноним
0
var
x,max:real;
n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
begin
write('Введите число ',i,': ');
readln(x);
if x<0 then
begin
if max=0 then max:=x; // если это первое отр.число
if x>max then max:=x
end
end;
writeln('Наибольшее среди отрицательных: ',max)
end.
x,max:real;
n,i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=1 to n do
begin
write('Введите число ',i,': ');
readln(x);
if x<0 then
begin
if max=0 then max:=x; // если это первое отр.число
if x>max then max:=x
end
end;
writeln('Наибольшее среди отрицательных: ',max)
end.
Новые вопросы
Английский язык,
2 года назад
Русский язык,
2 года назад
Алгебра,
10 лет назад
История,
10 лет назад
Физика,
10 лет назад