Написать программу в паскале: Дано натуральное число n. Заменить порядок следования цифр числа n на обратный.
Ответы на вопрос
Ответил Аноним
0
var
n,x:string;
i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=length(n) downto 1 do x:=x+n[i];
writeln('Обратное число: ',x)
end.
или можно так:
var
n:string;
begin
write('Введите число n: ');
readln(n);
writeln('Обратное число: ',ReverseString(n) )
end.
n,x:string;
i:integer;
begin
write('Введите число n: ');
readln(n);
for i:=length(n) downto 1 do x:=x+n[i];
writeln('Обратное число: ',x)
end.
или можно так:
var
n:string;
begin
write('Введите число n: ');
readln(n);
writeln('Обратное число: ',ReverseString(n) )
end.
Ответил Аноним
0
Так пойдет?
Ответил mednadia2011
0
да пойдет спасибо
Ответил Аноним
0
var a, N: integer;
begin
writeln('Введите число');
readln(N); a:=0;
while N>0 do begin
a:=a*10+N mod 10;
N:=N div 10;
end;
writeln (a);
readln;
end.
begin
writeln('Введите число');
readln(N); a:=0;
while N>0 do begin
a:=a*10+N mod 10;
N:=N div 10;
end;
writeln (a);
readln;
end.
Новые вопросы
Математика,
2 года назад
Українська мова,
2 года назад
Химия,
10 лет назад
Алгебра,
10 лет назад
Геометрия,
10 лет назад
Математика,
10 лет назад