Информатика, вопрос задал MQTR3 , 7 лет назад

Написать программу в Паскале

Дано двузначное число. Определить:
а) какая из его цифр больше: первая или вторая;
б) является ли сумма его цифр двузначным числом и чётна ли сумма его цифр.

Ответы на вопрос

Ответил ingr
0

var

   a : integer;

   d1, d2, s : integer;

begin

   write('введите двузначное число: ');

   readln(a);

   writeln('число: ', a);

   if (a < 100) and (a > 9) then begin

       d1 := a div 10;

       d2 := a mod 10;

       if d1 < d2 then writeln(d1, ' < ', d2, ' вторая цифра больше')

       else if d1 > d2 then writeln(d1, ' > ', d2, ' первая цифра больше')

       else writeln(d1, ' = ', d2, ' цифры равны');

       s := d1+d2;

       write('сумма цифр ', d1, '+', d2, '=', s);

       if s < 10 then write(' однозначное, ') else  write(' двузначное, ');

       if s mod 2 = 0 then write('четное ') else write('не четное ');

       writeln('число');

   end

   else writeln('это не двузначное число');

end.

Ответил MQTR3
0
Спасибо
Новые вопросы