написать программу в паскале
Дан размер фотографии ab см. Этот снимок был отсканирован с разрешением
600 пиксел/дюйм, цвет каждого пиксела представляется 24-битным кодом. Выразить размер файла
без сжатия в битах, байтах, Мбайтах. 1 дюйм = 25.4 мм.
Ответы на вопрос
Ответил huston81
1
Ответ:
pascal
Объяснение:
program photo;
var
a, b: integer;
begin
WriteLn('Введите размер фотографии в см: ');
Write('длина: '); ReadLn(a);
Write('ширина: '); ReadLn(b);
WriteLn('Размер отсканированного изображения разрешением 600 пиксел/дюйм');
WriteLn('при 24-битном кодировании будет равен:');
WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24:12:2, ' бит');
WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24 / 8:12:2, ' байт');
WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24 / 8 / 1024:12:2, ' Кбайт');
WriteLn((a / 2.54 * 600) * (b / 2.54 * 600) * 24 / 8 / 1024 / 1024:12:2, ' Мбайт');
end.
Новые вопросы