Информатика, вопрос задал PAPICH228 , 8 лет назад

Написать программу в Паскале 1. Заданы стороны треугольника. Проверить является ли он прямоугольным

Ответы на вопрос

Ответил Аноним
0
PascalABC.NET 3.4.0, сборка 1675 от 12.06.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadArrReal('Введите длины сторон:',3);
  a.Sort;
  if Sqr(a[2])=Sqr(a[0])+Sqr(a[1]) then Writeln('Треугольник прямоугольный')
  else Writeln('Треугольник не прямоугольный')
end.
Новые вопросы