Информатика, вопрос задал Katreen1 , 10 лет назад

Написать программу в Паскале:

 

1) Вводятся 10 целых чисел. Подсчитать количество четных среди них

 

2) Вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры).

 

3) Вывести на экран все трехзначные числа-палиндромы, т.е. такие числа, которые одинаково читаются как слева направо, так и справа налево.

 

Ответы на вопрос

Ответил emblerik
0

var

  i, c : byte;

  t : integer;

begin

  c := 0;

  for i := 1 to 10 do

  begin

    read (t);

    if t mod 2 = 0 then inc (c);

  end;

  writeln (c);

end.

 

var

  n, i : integer;

begin

  read (n);

  for i := 100 to 999 do

    if i mod 10 + i div 10 mod 10 + i div 100 = n then writeln (i);

end.

 

var

  i : integer;

begin

  for i := 100 to 999 do

    if i mod 10 = i div 100 then writeln (i);

end.

Новые вопросы