Информатика, вопрос задал mednadia2011 , 10 лет назад

написать программу в паскале:1.Дано целое число. Вычислить, если возможно, натуральный логарифм этого числа и вывести его на экран. В противном случае вывести сообщение об ошибке.

Ответы на вопрос

Ответил Аноним
0
Логарифм существует только для положительных чисел.
Поэтому напишем такую программу:

var  x:integer;
BEGIN
writeln('Введите число');
readln(x);
if  x<=0 then 
     writeln('Логарифм этого числа не существует')
     else write('ln=',ln(x))
END.
Новые вопросы