Написать программу в паскалabc
Даны 3 числа. Определить, можно ли построить треугольник с указанными сторонами.
Ответы на вопрос
Ответил Amarina9
0
Program triangle;
var
max,a,b,c,s:integer;
begin
readln(a,b,c);
max:=a;
if b > max then begin
max:=b;
s:=a+c;
if s > max then writeln('Мoжно')
else
writeln('Нельзя');
end;
if c > max then begin
max:=c;
s:=a+b;
if s > max then writeln('Мoжно')
else
writeln('Нельзя');
end
else
s:=c+b;
if s > max then writeln('Мoжно')
else writeln('Нельзя');
end.
var
max,a,b,c,s:integer;
begin
readln(a,b,c);
max:=a;
if b > max then begin
max:=b;
s:=a+c;
if s > max then writeln('Мoжно')
else
writeln('Нельзя');
end;
if c > max then begin
max:=c;
s:=a+b;
if s > max then writeln('Мoжно')
else
writeln('Нельзя');
end
else
s:=c+b;
if s > max then writeln('Мoжно')
else writeln('Нельзя');
end.
Новые вопросы