Информатика, вопрос задал serjei , 8 лет назад

Написать программу в паскаль
Ввести текст состоящий из слов , разделённых между собой запятыми.
Сколько раз в тексте встречается слова "Мама" В найденных словах изменить букву "М" на букву "П"
Так же нужно прописать программу простую и понятную по синтаксису

Ответы на вопрос

Ответил Aillianna
0
//PascalABC.NET версия 3.2, сборка 1367
begin
    var s := ReadlnString('>');
    var r := new Regex('bМамаb');
    Writeln('Количество слов "Мама": ', r.Matches(s).Count);
    s := r.Replace(s, 'Пама');
    s.Println;
end.

все просто и понятно)
только экранирующие символы пришлось поискать для слова целиком

Пример работы программы:
> Мама,Мамам,Мама,мама,Мама
Количество слов "Мама": 3
Пама,Мамам,Пама,мама,Пама


Новые вопросы